Apple Product Availability

Incident Report for ElectricAI

Resolved

Most popular options are once again available in our Storefront, and we are working with both Apple and our fulfillment partners to ensure the full lineup is restored shortly.
Posted Jun 29, 2026 - 09:27 EDT

Identified

Apple products are temporarily unavailable in the hardware store. We're working with Apple to resolve this - please check back soon.
Posted Jun 25, 2026 - 11:51 EDT
This incident affected: Electric IT Hub (Hardware Procurement).