IT Hub Login outage
Incident Report for Electric
Resolved
The issue was resolved.
Posted Apr 03, 2024 - 16:07 EDT
Monitoring
A fix has been performed and now IT Hub is fully up.
Posted Apr 03, 2024 - 16:02 EDT
Identified
We were able to identify the root cause of this partial outage and are now taking steps to remediate it.
Posted Apr 03, 2024 - 15:54 EDT
Investigating
IT Hub is experiencing an outage that affects users trying to login into it
Posted Apr 03, 2024 - 15:49 EDT
This incident affected: Third-Party Applications (Login/SSO).