Degraded Performance in Turbine
Incident Report for Electric
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 11:30 EST
Identified
Our team has identified that this incident is isolated to users accessing Turbine via Chrome. We will continue to troubleshoot and provide updates as we move toward a resolution. In the interim, all users are advised to use Safari or Firefox to access Turbine.
Posted Nov 30, 2022 - 11:17 EST
Investigating
Some users may experience degraded performance in Turbine. Our teams are actively investigating the issue and will provide regular updates as soon as possible.
Posted Nov 30, 2022 - 10:25 EST
This incident affected: Electric Services (Device Management, Service Desk Correspondence, Onboarding and Offboarding, Reporting, Managed Applications).