Employee synchronization with certain HR systems

Incident Report for ElectricAI

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 12:48 EDT

Monitoring

A fix for this is in the process of being deployed and we will continue to monitor.
Posted Sep 18, 2026 - 12:21 EDT

Identified

Due to an upstream issue, certain HR systems may experience degraded performance with Employee synchronization. A root cause has been identified and remediation of the issue is actively underway.
Posted Sep 18, 2026 - 12:01 EDT