SMS MFA Degraded Functionality

Incident Report for ElectricAI

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 14:38 EDT

Identified

Users relying on SMS for MFA might not receive their OTP messages. Users relying on authenticator apps such as Google Authenticator are not affected.
Posted Jun 09, 2025 - 12:26 EDT