Slack - Channels Issues
Incident Report for Electric
Resolved
This incident has been resolved.
Posted May 23, 2023 - 16:36 EDT
Identified
Slack has reported an incident that may impact some users ability to load channels, and add users to channels. This should not impact our chat support via Slack, but if you are experiencing issues reaching out to us through chat please submit a ticket via the Electric User Hub (https://requests.electric.ai/)

You may reference the Slack status page here: https://status.slack.com/
Posted May 23, 2023 - 12:32 EDT
This incident affected: Electric Services (Device Management, Service Desk Correspondence, Onboarding and Offboarding, Reporting, Managed Applications) and Third-Party Applications (Slack Apps/Integrations, Slack Apps/Integrations/APIs, Slack Posts/Files, Slack Messaging, Slack Login/SSO).