Microsoft 365 Outage
Incident Report for Electric
Resolved
This incident has been resolved.
Posted Apr 21, 2023 - 09:44 EDT
Identified
Microsoft has determined that a section of caching infrastructure is performing below acceptable performance thresholds, causing calls to gather user licensing information to bypass the cache and go directly to Azure Active Directory infrastructure resulting in high resource utilization, resulting in throttling and impact. They are analyzing forensics within the caching infrastructure to identify the cause of the issue.
Posted Apr 20, 2023 - 12:45 EDT
Investigating
Microsoft is currently reporting performance issues across their 365 suite of apps. As a result, customers may have issues accessing the web applications, such as Excel Online.

Our agents have found that users can still access the applications directly through their URLs:

Microsoft 365 Admin Center - portal.office.com
Outlook - outlook.office.com
Microsoft Teams - teams.microsoft.com
Word Online - microsoft365.com/launch/word
Excel Online - microsoft365.com/launch/excel

You may visit the MS365 status here for updates: https://twitter.com/MSFT365Status
Posted Apr 20, 2023 - 12:44 EDT
This incident affected: Electric Services (Managed Applications).