Captchas Nonfunctional

Incident Report for ElectricAI

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 17:07 EDT

Monitoring

A fix for the issue has been implemented and is being deployed.
Posted Jul 20, 2026 - 16:55 EDT

Identified

Captchas are currently not functioning as expected within the application. The issue's root cause has been identified and remediation steps are being taken presently.
Posted Jul 20, 2026 - 15:55 EDT