Gigawatt Not Responding to New Requests

Incident Report for ElectricAI

Resolved

This incident has been resolved.
Posted May 19, 2026 - 16:35 EDT

Investigating

We are investigating an issue where responses from Gigawatt are not being returned to users.
Posted May 19, 2026 - 16:32 EDT
This incident affected: Electric IT Hub (AI-Powered Support).