Delayed or Degraded Message Performance
Incident Report for Electric
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 21:00 EDT
Identified
There is newly discovered degraded performance with Service Desk Correspondence, likely a result of the previously noted AWS issue.
Posted Jun 13, 2023 - 18:21 EDT
This incident affected: Electric Services (Service Desk Correspondence).