Kaseya Maintenance Impacting MDM Tasks
Incident Report for Electric
Resolved
While we have not yet received official confirmation from Kaseya that the incident has been resolved, we have seen that all operations have been fully restored.
Posted Oct 25, 2021 - 12:41 EDT
Identified
We have identified an issue with one of our MDM providers, Kaseya, where our ability to perform certain remote tasks is taking longer than expected. Tasks may include, but are not limited to, remote troubleshooting, entering admin passwords, or remote provisioning. As a result, our Service Desk team may require you to wait for the issue to be resolved in order to assist, or schedule a future session.

We are actively monitoring the issue with Kaseya and will provide updates as we have more information.
Posted Oct 22, 2021 - 13:32 EDT
This incident affected: Electric Services (Device Management, Service Desk Correspondence).