Turbine | Stored Inventory Not Displaying
Incident Report for Electric
Resolved
This incident has been resolved.
Posted May 12, 2023 - 11:37 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2023 - 11:30 EDT
Identified
Electric's 3rd party inventory tracking platform is currently experiencing an outage that is affecting Turbine's ability to display device inventory stored at Electric for Onboarding.

Agents are able to access the platform independently to assist with information around stored inventory and guidance for Onboardings.

We are monitoring the situation with our inventory partner and will provide updates as they become available.
Posted May 12, 2023 - 09:56 EDT
This incident affected: Electric Services (Device Management).