Ticketing Delays: Electric Service Desk Correspondence
Incident Report for Electric
Resolved
This incident has been resolved.
Posted Nov 18, 2022 - 13:22 EST
Monitoring
Our team has identified and implemented a fix; customers can now expect restored functionality to chat for new tickets. We will be monitoring activity to ensure the ticketing system continues to function properly.

If you are still experiencing problems with chat, please reach out to Electric via the Electric User Hub: https://requests.electric.ai/
If you don't have an account yet, learn how to create one here: https://support.electric.ai/en_us/create-euh-account-SJ57rO5zi
Posted Nov 18, 2022 - 12:33 EST
Investigating
Electric is currently experiencing an issue affecting communication through our ticketing system. This may prevent customers from receiving messages from Electric via chat. Correspondence via the Electric User Hub is not impacted. As we work to resolve this issue, it is recommended that customers utilize the Electric User Hub for all support requests.

You can access the Electric User Hub here: https://requests.electric.ai/
If you don't have an account yet, learn how to create one here: https://support.electric.ai/en_us/create-euh-account-SJ57rO5zi

We will continue to troubleshoot the incident and provide an update as soon as possible.
Posted Nov 18, 2022 - 09:00 EST
This incident affected: Electric Services (Service Desk Correspondence).