Ticketing Delays: Third Party Incident
Incident Report for Electric
Resolved
This incident has been resolved.
Posted Nov 28, 2023 - 10:44 EST
Investigating
Electric is aware of an event occurring with one of our third-party vendors affecting communication through our ticketing system. This may prevent customers from sending or receiving messages through messaging apps, email, or the Electric platform.

Our team will continue to take action from our side and will proactively monitor the status with our vendor. Please expect further updates within the next hour.
Posted Nov 27, 2023 - 16:38 EST
This incident affected: Electric Services (Service Desk Correspondence, Onboarding and Offboarding).