Warehouse Outage

Incident Report for ElectricAI

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 17:57 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 28, 2026 - 09:38 EDT

Monitoring

Our warehouse is currently experiencing an outage that is preventing both the intake of inbound devices and outbound shipments.

We are monitoring the situation closely and will provide updates as we have them.
Posted Apr 27, 2026 - 17:35 EDT
This incident affected: Hardware Warehousing.