AWS Outage Caused Turbine Outage -- No Outstanding Issues.
Incident Report for Electric
Resolved
All services have continued to be confirmed operational for some time. AWS Lambda synchronous invocation APIs have recovered.
Posted Jun 13, 2023 - 17:59 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 13, 2023 - 17:43 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 13, 2023 - 17:42 EDT
Update
Outstanding Service Desk Correspondence issues have been resolved. We are continuing to monitor for any potential or remaining issues.
Posted Jun 13, 2023 - 17:40 EDT
Update
While monitoring for issues, a major issue with ticketing was detected. We are actively working to resolve the issue.
Posted Jun 13, 2023 - 16:59 EDT
Update
The issue with AWS Lambda functions which caused the outage have been partially resolved and Electric is back up. We are carefully monitoring to ensure any remaining issues are quickly addressed.
Posted Jun 13, 2023 - 16:48 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 13, 2023 - 15:21 EDT
Monitoring
We are continuing to work on a fix for this issue.
Posted Jun 13, 2023 - 15:19 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 13, 2023 - 15:18 EDT
Identified
An AWS outage is causing a general outage of Turbine and associated functionality. We are actively investigating.
Posted Jun 13, 2023 - 15:12 EDT
This incident affected: Electric Services (Device Management, Service Desk Correspondence, Onboarding and Offboarding, Reporting, Managed Applications).