Email Ticket Delays: Third Party Incident
Incident Report for Electric
Resolved
This incident has been resolved.
Posted Feb 03, 2023 - 14:37 EST
Investigating
Electric is aware of an event reported by one of our third-party vendors affecting communication through our email ticketing platform and Electric User Hub. This may cause delays when sending or receiving email messages and Electric User Hub messages with our support agents.

Our team will continue to take action from our side and will proactively monitor the status with our vendor. We will provide updates as we receive them.
Posted Feb 03, 2023 - 11:41 EST
This incident affected: Electric Services (Service Desk Correspondence, Onboarding and Offboarding).