Chat Support - Response Delays
Incident Report for Electric
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 07:57 EDT
Monitoring
A fix has been implemented on Kustomer's end and we are monitoring the results. As a result of this incident, however, there may still be a delay in agent responses as we catch up with the queue of tickets.
Posted Oct 14, 2021 - 12:07 EDT
Identified
The issue has been identified and we are working with our ticketing platform, Kustomer, to resolve.

In the meantime, you can check the status of the issue on Kustomer's status page: https://status.kustomer.com/#
Posted Oct 14, 2021 - 11:11 EDT
Investigating
Our team has reported an incident with our ticketing system that may impact some users ability to receive responses from the Service Desk team - via Slack, Teams or Email. This will result in longer wait times between responses. We are actively investigating the issue and will provide a status update soon.
Posted Oct 14, 2021 - 10:49 EDT
This incident affected: Electric Services (Service Desk Correspondence).