Microsoft 365 Email Sync Issues
Incident Report for Electric
Resolved
Microsoft has updated that the issue has been resolved
Posted Jun 23, 2022 - 13:32 EDT
Monitoring
Microsoft has stated that they have deployed their fix to approximately 96% of the affected infrastructure and are continuing to monitor the deployment's progress to ensure that it completes and impact is resolved as expected.

For the most up to date status, please visit: https://portal.office.com/servicestatus
Posted Jun 23, 2022 - 10:01 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 22, 2022 - 17:01 EDT
Investigating
Microsoft is currently reporting with the sync from external email servers to their email clients (Outlook Mobile or Outlook for Mac).
This includes mail coming from Google, Yahoo, and iCloud that is being viewed and managed through Outlook
For more information and the most up to date status report of the issue you may visit the Microsoft Office status page here for detailed updates: https://portal.office.com/servicestatus
Posted Jun 22, 2022 - 16:43 EDT
This incident affected: Electric Services (Managed Applications).